Frage:

Frage: Fotos 3 sehr träge :-( was ist los ???

Ich habe meinen iMac (27 Zoll, Mitte 2010, i3 3,2Ghz, 12GB RAM) gerade frisch auf High Sierra 10.13.2 aktualisiert und hab damit Fotos 3 Version 3.0 (3251.12.190) installiert bekommen.


Bin gerade zurück aus einem Marokko-Urlaub und habe fas 700 neue Bilder in Fotos zu der bestehenden Bibliothek mit 25000 Bildern importiert.


Sehr erfreut war ich über die neuen Bearbeitungsfunktionen - endlich wird das Programm professioneller - hurra !


Aber nachdem die Bearbeitung bei den ersten 200 Bildern recht flott von Statten ging ist nun heute irgendeine Bremse drin. Ich habe nur Safari, Mail und Fotos geöffnet - genutzt werden dann nur knapp 4GB des Speichers, und mit 12GB RAM ist ja auch ausreichend Reserve da. Daran kanns also nicht liegen.


Nach dem Start von Fotos krallt sich das erstmal die ganze Rechnerperformance und es dauert eine Minute, bis das nachläßt und man dann aber wieder wie gewohnt schnell durch die Bilder scrollen kann.


Sobald ich dann aber auf das Bearbeiten der Bilder springe und dort z.B. "Anpassen" auswähle geht alles in die Knie :


Der Wechsel von einem Bild zum nächsten wird zur Tortur, es dauert mehrere Sekunden bis das nächste Vorschaubild in voller Auflösung angezeigt wird und die "Anpassen"-Tools wieder zur Verfügung stehen. Gleiches Spiel beim Wechsel der Tools. Geht man während diesen "Warteschleifen" zum Beispiel zurück hier in Safari um weiterzutippen ist auch hier plötzlich alles ganz träge, das komplette System mitsamt anderer Applikationen macht ne Warteschleife.


Ich habe iStatMenus installiert und dann daher die Prozessor-Auslastung auch beobachten - merkwürdigerweise liegt die dann nicht wie vermutet bei 100% sondern es ist immer noch "Luft" da, i.d.R. zwischen 20-50% !


Und doch läuft der Rechner wie wenn Sand im Getriebe wäre. Was wirklich merkwürdig ist, das er die ersten 150-200 Bilder doch recht zügig durchgearbeitet hat :-(


Irgend eine Idee was zu tun ist ?


Im übrigen benutzte ich auf dem gleichen Rechner auch Aperture 3.6 (für andere Projekte), das wesentlich aufwändigere Bearbeitungsoptionen hat - aber nicht diese Probleme. Wäre das Programm nicht von Apple eingestellt (und damit eine Sackgasse) hätte ich neuere Projekte nicht auf Fotos umgestellt. Uns steht jetzt wieder einmal wie doof da weil ich die neuen Bilder nicht im Umfeld präsentieren kann - weil Fotos lahme. Na super, Apple ... .

iMac, macOS High Sierra (10.13.2), Fotos Version 3.0 (3251.12.190)

Gepostet am

Antworten
Frage gekennzeichnet als Gelöst
Antwort:
Antwort:

Roland, die Aktualisierung von Fotos hat nicht nur neue Anpassungen gebracht, sondern auch eine Aktualisierung der Gesichtererkennung und der automatischen Klassifikation von Fotos anhand der Objekte in den Fotos. Und das heisst, dass nach der Aktualisierung auf Photos 3.0 die gesamte Mediathek neu gescannt wird. Für alle Fotos läuft die Objekterkennung und die Gesichtererkennung noch einmal. das kann für eine grosse Mediathek tagelang so gehen. Die Analyse der Bilder für sollte eigentlich im Hintergrund laufen, wenn man nicht mit Fotos arbeitet und es wenig stört, aber es scheint auch zu laufen, wenn man ein Bild ausschneidet oder retuschiert, weil durch die Bearbeitung dann Objekte und Personen verschwinden können. Machst du viele Bildausschnitte oder retouchierst in externen Editoren?

Gepostet am

Seiteninhalt wurde geladen

Frage gekennzeichnet als Gelöst

16. Dez. 2017, 08:07 als Antwort auf rolandgoetz Als Antwort auf rolandgoetz

Roland, die Aktualisierung von Fotos hat nicht nur neue Anpassungen gebracht, sondern auch eine Aktualisierung der Gesichtererkennung und der automatischen Klassifikation von Fotos anhand der Objekte in den Fotos. Und das heisst, dass nach der Aktualisierung auf Photos 3.0 die gesamte Mediathek neu gescannt wird. Für alle Fotos läuft die Objekterkennung und die Gesichtererkennung noch einmal. das kann für eine grosse Mediathek tagelang so gehen. Die Analyse der Bilder für sollte eigentlich im Hintergrund laufen, wenn man nicht mit Fotos arbeitet und es wenig stört, aber es scheint auch zu laufen, wenn man ein Bild ausschneidet oder retuschiert, weil durch die Bearbeitung dann Objekte und Personen verschwinden können. Machst du viele Bildausschnitte oder retouchierst in externen Editoren?

16. Dez. 2017, 08:07

Antworten Hilfreich (1)

15. Dez. 2017, 18:18 als Antwort auf Leonie Als Antwort auf Leonie

Hi,


ich bearbeite meine Bilder oft nach : Bildausschnitt, Farbkorrekturen, usw. - die neuen Tools von Fotos 3 sind dazu endlich auch gut geeignet. Mit einem externen Editor arbeite ich nicht. Hab früher Problembilder eher in Aperture geladen, dort korrigiert/bearbeitet und dann rüber nach Fotos geschoben.



Hab gerade ONYX auf dem iMac laufen lassen - wollte sicher gehen das es nicht an irgendwelchen Cache-Dateien oder anderen Geschichten liegt. Nach dem Neustart ist das Verhalten von Fotos 3 unverändert :

geht man in den Bearbeiten-Modus dauert es fast 30sek bis das Bild bearbeitbar ist. Dazwischen ist einfach alles blockiert, eingefroren, auch ein Wechsel zu Safari ist nicht möglich. iStatMenu wie auch die systemeigene Aktivitätsanzeige zeigen jedoch keine Auffälligkeiten ?!? Prozessorlast wie auch Speicherauslastung : alles okay.
Von irgendwelchen Hintergrund-Rechnereien : nix zu sehen.
Nach ein paar Bildern mit elender Pause flutscht es dann plötzlich über 15-20 Bilder mit dem Bearbeiten.
Dann wird's wieder langsamer - und ein xpcproxy-Prozess taucht auf, der das System bis 90% auslastet. Der verschwindet dann wieder - und geht in der gleichen zähen Weise wie zuvor weiter - mit elenden Wartepausen.
Prozessorauslastung liegt aber bei 3-10% ... .

Und ein paar Minuten später geht's dann wieder flott von einem Bild zum anderen ...

Spring ich dann zurück in die Listanzeige sind dort erstmal nur noch weisse Platzhalter - und es dauert 15Sek bis die Vorschauen wieder auftauchen. Wieder : keine Prozessorauslastungs-Peak in iStatMenu - einfach eine Denkpause ?


Also alles recht merkwürdig :-( ...

15. Dez. 2017, 18:18

Antworten Hilfreich

16. Dez. 2017, 09:19 als Antwort auf rolandgoetz Als Antwort auf rolandgoetz

xpcproxy ist ja für die Interprozesskommunikation da - es legt die caches an, über die andere Programme auf die Fotosmediathek zugreifen können. Das routinemässige Leeren der Caches kann den Mac langsam machen, weil einige caches viel Rechenzeit erfordern, um sie wieder zu füllen.

Benutzt du iCloud Fotomediathek? Falls die Fotos in iCloud Fotomediathek sind, müssen sie dafür aus iCloud geladen werden, damit xpcproxy die Caches wieder füllen kann.


ich habe auf meinem Mac mal gesucht, wo überall so Fotos in den Caches liegen. Besonders gross ist dieses Cache auf meinem Mac: es enthält Fotos und Videos für den Mediabrowser:

~/Library/Containers/com.apple.MediaLibraryService/Data/Library/Caches/com.apple .iLifeMediaBrowser.ILPhotosTranscodeCache


Seit dem Upgrade auf High Sierra finde ich dort Kopien aller Videos und und Fotos, die im meiner Mediathek im HEIC oder HEVC Format gespeichert sind. Falls du ein iPhone benutzt, dass in HEIC oder HEVC aufnehmen kann, wird der xpcproxy wahrscheinlich mit der Videokonversion beschäftigt sein.

16. Dez. 2017, 09:19

Antworten Hilfreich

18. Dez. 2017, 22:23 als Antwort auf Leonie Als Antwort auf Leonie

Hi Leonie, danke für die weiteren Erläuterungen. Gerade das mit dem xpcproxy ist mir schon früher unter High Sierra aufgefallen - bei einer Mediathek mit 26000 Bildern (* war Fotos wohl schon eine Weile beschäftigt mit dem Cache-Aufbau ... .

Der angeben Ordner in der Library ist bei merkwürdigerweise aber leer - zumindest bekomme ich keinen Inhalt angezeigt ?!


Nein, ich benutzte nicht die iCloud Fotomediathek. Wüsste nicht wofür - ich speichere meine Bilder lokal. Die Fotos Library hat bei mir 136GB - das ist keine Datenmenge die ich mit irgendeiner Cloud synchronisieren will. Kann also nicht die Ursache sein. Mit Videos arbeite ich auch auch nicht.


Ich habe dagegen heute mal die Bilder meiner Kamera (Pentax K3) im RAW Format importiert und bearbeiten wollen. Da geht die Rechenleistung völlig in die Knie - der Prozessor ist lt. iStatMenu stets bis an den Rand belastet, die Bearbeitung (cropping, drehen, weisabgleich anpassen,etc.) ist unglaublich zäh.


Hab mal die gleichen Bilder parallel in Aperture gezogen - dort geht's butterweich - und wo beide Programme gleichzeitig im Speicher sind (wie gesagt, die 12GB RAM sind nie komplett ausgelastet). Auch der Grafikkonverter 10 (zusätzlich noch gestartet) öffnet die Bilder wesentlich fixer und ist in der Bearbeitung deutlich sehr viel schneller.
Mir scheint das Fotos hier echt noch einen enormen Nachholbedarf in der Optimierung hat :-(((


So kann ich auf jeden Fall nicht damit arbeiten - ich benötige die 3-fache Zeit ...


(* naja, sooo viel Bilder sind das ja nicht mal - ich hab schon Laptops von Teenies ausgemistet, die mit 25000 Bildern und Videos (iPhone macht's möglich ...) innerhalb von 2-3 Jahren zugemüllt worden und dann aufgrund Speichermangel in die Knie gegangen sind.

18. Dez. 2017, 22:23

Antworten Hilfreich

19. Dez. 2017, 15:18 als Antwort auf rolandgoetz Als Antwort auf rolandgoetz

Du könntest noch folgende Tests machen, um das Problem etwas einzugrenzen:

  • Hast du mal getestet, ob eventuell die Mediathek ein Problem hat? Lege eine neue Testmediathek an und importiere ein paar Fotos. geht es in der neuen Mediathek besser?
  • Und um zu sehen, ob eventuell in deinem Benutzeraccount problematische Caches oder plinst-dateien sind, mache denselben Test in einem anderen Benutzeraccount, z.B. als Gastbenutzer. Wenn es für einen anderen Benutzeraccount besser klappt, weisst du, dass es kein systemweites Problem ist.

19. Dez. 2017, 15:18

Antworten Hilfreich
Benutzerprofil für Benutzer: rolandgoetz

Frage: Fotos 3 sehr träge :-( was ist los ???