Annonce: Préparez-vous à découvrir macOS Mojave


Avec des fonctionnalités comme le Dark Mode, Stacks et quatre nouvelles applications intégrées, macOS Mojave vous aide à tirer le meilleur parti de chaque clic. Venez découvrir les nouveautés de macOS Mojave ici > https://support.apple.com/fr-fr/macos/mojave

Question :

Question : Problème OS High sierra et java 6

J'ai une application java (java 6) qui fonctionne correctement avec les différentes versions de mac os x. Depuis la mise à jour vers High Sierra l'application indique des erreurs exception java :

Interception d'une exception java.lang.RuntimeException: Non-Java exception raised, not handled! (Original problem: Deprecated in 10_12... DO NOT EVER USE CGSEventRecord directly. Bad things, man.... bad things.)

cela arrive dès que l'on entre des données. Quelqu'un a t-il une idée? J'ai vu que sur le site anglais une nouvelle version java 6 avait été créé. Je l'ai installée mais sans plus de succès.

~VIN,MacBook Pro (17-inch Mid 2010), macOS High Sierra (10.13), java 6

Publiée le

Répondre

Le contenu de la page a été chargé

17 nov. 2017 à 03h16 en réponse à philfr En réponse à philfr

https://www.java.com/fr/download/faq/yosemite_java.xml


Pour le moment il ne semble pas exister de version de Java pour Mac OS X 10.13, il vous faudra attendre ou demander au développeur de l’application mettre à jour pour Java 8 et suivant...

17 nov. 2017 à 03h16

Répondre Utile
Profil de l’utilisateur : philfr

Question : Problème OS High sierra et java 6