Annonce:

C'est officiel !! La chaîne YouTube de l'assistance Apple est en ligne. Abonnez-vous et obtenez des conseils d'utilisations et astuces utiles venant directement d'Apple.

Chaine officielle Apple sur Youtube

Question :

Question : Tableau Numbers sans "blanc"

Bonjour.

Je souhaite faire, à partir d'un tableau de données, un second tableau qui ne contient qu'une partie des données du premier tableau, mais sans "trou" ou sans "blanc" (sans cellule vide interposée).

J'ai trouvé un modèle sous Excel, avec les formules :

=MIN(SI(NON(ESTVIDE(DECALER($A1:$A$10;NB.VIDE($A$1:$A1);;;)));LIGNE(DECALER($A1: $A$10;NB.VIDE($A$1:$A1);;;))))

et

=SI(B1="";"";SI(MIN(SI(NON(ESTVIDE(DECALER($A$1:$A$10;B1;;;)));LIGNE(DECALER($A$ 1:$A$10;B1;;;))))=0;"";MIN(SI(NON(ESTVIDE(DECALER($A$1:$A$10;B1;;;)));LIGNE(DECA LER($A$1:$A$10;B1;;;))))))

Mais je n'arrive pas à les adapter pour Numbers.

Quelqu'un pourrait-il me faire la conversion de ces formules, stp ?

Merci d'avance pour votre aide.

Bien cordialement,

Pascou47

iMac (Retina 5K, 27-inch, Late 2014), iOS 11.2

Publiée le

Répondre
Question marquée comme Résolu
Réponse :
Réponse :

Voici ce que j'ai trouvé sur le Net (un grand merci à celui ou à celle qui avait trouvé la solution).

En l'adaptant à mon cas précis, ça fonctionne très bien.

Je te remercie à nouveau de t'être penché sur mon problème.

Bonne fêtes de fin d'année à toi ainsi qu'à tous tes proches.

Dans le tableau auxiliaire dont je supposerai qu'il est doté d'une ligne d'en-tête avec une valeur dans la cellule A1,

en A2 saisir :

=SI(NB.SI(Tableau 1::A$1:A2;Tableau 1::A2)=1;Tableau 1::A2;"")

en B2 saisir :

=SI(A2>"";LIGNE();"")

en C2 saisir :

=SI.ERREUR(DECALER($A$1;PETITE.VALEUR(B;LIGNE()−1)−1;0;1;1);"")

Recopier vers le bas les trois formules.

La colonne C contiendra une liste continue des valeurs uniques

Publiée le

Question marquée comme Utile

18 déc. 2017 à 18h24 en réponse à Pascou47 En réponse à Pascou47

Bonjour,

il faut utiliser la formule « transpose »

Dans fonction, puis catégorie il faut aller dans Référence puis tout en bas la fonction transpose: (TRANSPOSE(intervalle-tableau)).

en clivant sur intervalle-tableau, il te suffit de toucher dans ton autre tableau la cellule de référence à transposer.

En espérant avoir répondu à ta question,

bonne soirée

Question marquée comme Utile

18 déc. 2017 à 18h24 en réponse à Djélux En réponse à Djélux

Bonjour.

Merci bcp pour ta réponse.

J'avoue que je ne suis pas très calé.

Même avec la très bonne explication que tu m'as donnée, j'ai du mal à faire mon tableau.

Je ne sais pas si c'est possible, mais pourrais-tu m'envoyer un tableau en exemple, stp ?

Merci encore pour ta contribution, c'est très gentil.

Bonne soirée également 😉 🙂

Cette conversation n’est pas terminée

Consulter toutes les réponses

Le contenu de la page a été chargé

Question marquée comme Utile

18 déc. 2017 à 18h24 en réponse à Pascou47 En réponse à Pascou47

Bonjour,

il faut utiliser la formule « transpose »

Dans fonction, puis catégorie il faut aller dans Référence puis tout en bas la fonction transpose: (TRANSPOSE(intervalle-tableau)).

en clivant sur intervalle-tableau, il te suffit de toucher dans ton autre tableau la cellule de référence à transposer.

En espérant avoir répondu à ta question,

bonne soirée

18 déc. 2017 à 18h24

Répondre Utile (1)
Question marquée comme Utile

18 déc. 2017 à 18h24 en réponse à Djélux En réponse à Djélux

Bonjour.

Merci bcp pour ta réponse.

J'avoue que je ne suis pas très calé.

Même avec la très bonne explication que tu m'as donnée, j'ai du mal à faire mon tableau.

Je ne sais pas si c'est possible, mais pourrais-tu m'envoyer un tableau en exemple, stp ?

Merci encore pour ta contribution, c'est très gentil.

Bonne soirée également 😉 🙂

18 déc. 2017 à 18h24

Répondre Utile (1)

18 déc. 2017 à 18h37 en réponse à Djélux En réponse à Djélux

Voici le modèle de tableau Excel que je souhaiterais adapter.

--> En ajoutant la lettre "o" dans la colonne Condition, le tableau de la colonne D insère les valeurs de la colonne A choisies, sans laisser d'espace entre les cellules.

Encore merci pour ton aide,

Bonne soirée.

Fichier chargé par un client

18 déc. 2017 à 18h37

Répondre Utile

18 déc. 2017 à 20h24 en réponse à Pascou47 En réponse à Pascou47

Idem je suis pas très calé mais à force de bricoler on trouve mais pas toujours et la je ne trouve pas .... grrr pour le moment.

Alors, petite rectification avec les info que tu m’as donné:

La formule est une condition (SI(expression-si);(si-vrai);(si-faux))

Donc j’ai utilisé (expression-si) qui correspond à la colonne B du premier tableau avec la condition que si elle est = à ’’o’’ (il faut utiliser =puis texte sur la barre des fonctions sinon ça ne marche pas)

Puis (si-vrai) je clique dessus et je valide la cellule dans le tableau 1 en A (couleur saumon)

enfin (si-faux) je clique dessus et je la remplace par « texte » et j’y insère un éspace c’est à dire si c’est faux il n’y a pas de conséquence.

Et pour appliquer la formule à toute la ligne du tableau: cliquer sur la cellule et utiliser :action de la cellule, remplissage automatique.

avec la fonction si tu peux y insérer toute sorte de condition il faut juste utiliser « texte » pour insérer la condition.

Par contre tu auras toujours ton blanc si la condition n’est pas validée : désolé

Fichier chargé par un client

Je vais y réfléchir et si je trouve une solution je te recontacte.

Encore désolé pour le faux espoir 😭

18 déc. 2017 à 20h24

Répondre Utile

19 déc. 2017 à 09h14 en réponse à Djélux En réponse à Djélux

Bonjour.

Merci bcp à toi pour cette avancée notable.

En effet, la suppression de ce "blanc" est toujours la condition recherchée...

Je planche moi aussi et je recherche sur le net, mais pas facile.

Le premier qui trouve prévient l'autre 😉

Encore un grand merci, c'est très gentil.

Bonne journée.

19 déc. 2017 à 09h14

Répondre Utile
Question marquée comme Résolu

23 déc. 2017 à 14h59 en réponse à Djélux En réponse à Djélux

Voici ce que j'ai trouvé sur le Net (un grand merci à celui ou à celle qui avait trouvé la solution).

En l'adaptant à mon cas précis, ça fonctionne très bien.

Je te remercie à nouveau de t'être penché sur mon problème.

Bonne fêtes de fin d'année à toi ainsi qu'à tous tes proches.

Dans le tableau auxiliaire dont je supposerai qu'il est doté d'une ligne d'en-tête avec une valeur dans la cellule A1,

en A2 saisir :

=SI(NB.SI(Tableau 1::A$1:A2;Tableau 1::A2)=1;Tableau 1::A2;"")

en B2 saisir :

=SI(A2>"";LIGNE();"")

en C2 saisir :

=SI.ERREUR(DECALER($A$1;PETITE.VALEUR(B;LIGNE()−1)−1;0;1;1);"")

Recopier vers le bas les trois formules.

La colonne C contiendra une liste continue des valeurs uniques

23 déc. 2017 à 14h59

Répondre Utile (1)

23 déc. 2017 à 19h05 en réponse à Djélux En réponse à Djélux

Merci beaucoup.

Je te souhaite tout plein de bonnes choses pour Noël et pour la nouvelle année.

Peut-être aurons nous l'occasion de partager d'autres informations...

Ce sera avec plaisir en tout cas.

Bonne soirée et bon réveillon pour demain (attention à ne pas trop picoler... ou à ne pas conduire après 😉 )

A bientôt,

Pascal

23 déc. 2017 à 19h05

Répondre Utile
Profil de l’utilisateur : Pascou47

Question : Tableau Numbers sans "blanc"