Question :

Question : Résultat inexact dans Numbers

Si j'additionne 3 cellules contenant chacune le résultat d'un pourcentage, le total des 3 cellules est inexact de 0,01$. La même opération dans Excel donne le résultat exact. Est-il possible que Numbers calcule plus de chiffres après le point que Excel ce qui expliquerait cette différence? Comment faire pour créer une formule qui prendrait le nombre en devise d'une cellule X 5%= Résultat arrondi à 2 chiffes après le point?

MacBook Air, iOS 11.2.6

Publiée le

Répondre
Question marquée comme Résolu
Réponse :
Réponse :

@chilston:

Cellule L6

=ARRONDI(J6×3,5%;2)

Cellule M6

=ARRONDI((J6+K6+L6)×5%;2)

Cellule N6

=ARRONDI((J6+K6+L6+M6)×9,5%;2)

Publiée le

Cette conversation n’est pas terminée

Consulter toutes les réponses

Le contenu de la page a été chargé

22 févr. 2018 à 03h23 en réponse à anet En réponse à anet

Pour arrondir, il y a la fonction ARRONDI(nbre-à-arrondir; décimales). Par exemple:

=ARRONDI(1,23456; 2)

vous donnera 1,23. Supposons que c'est la cellule B3 qui contient 1,23456. La formule:

=ARRONDI(B3; 2)

vous donnera aussi 1,23. Supposons que vous voulez 5% de B3. Vous pouvez faire:

=ARRONDI(B3*0,05; 2)

22 févr. 2018 à 03h23

Répondre Utile

22 févr. 2018 à 18h43 en réponse à anet En réponse à anet

J'ai exactement le même problème mais je n'y arrive pas. Si on additionne J6 à O6, le résultat devrait être 472,39$. En utilisant la formule ARRONDI proposée, je réussi à l'intégrer seulement dans la cellule L6.Voici l'exemple d'une feuille de calcul pour un hôtel:

  • En B6= somme des Locations de chambres + Forfaits+ Taxe d'hébergement du Québec+Taxe fédérale+Taxe Provinciale + Ajustement
  • J6= Total des locations de chambres
  • K6= Forfaits taxables seulement en TPS & TVQ
  • L6= J6 X 3.5% (Taxe hébergement du Québec THQ)
  • M6= Somme de J6,K6,L6 X 5% (Taxe Fédérale TPS)
  • N6= Somme de J6,K6,L6,M6 X 9.5% (Taxe provinciale du Québec TVQ)
  • O6= Ajustement de la caisse enregistreuse en + ou en -

Fichier chargé par un client

22 févr. 2018 à 18h43

Répondre Utile (1)
Profil de l’utilisateur : anet

Question : Résultat inexact dans Numbers