Question :

Question : Menu local imbriqué

Bonjour,


J’utilise Numbers avec mon IPad Air 2, et le dernier IOS.


Comment faire pour :

- que le contenu d’un menu local s’affiche en fonction du résultat d’une autre cellule ?

- qu’un menu local dépende du résultat d’un précédent menu local ?


Situation : je souhaite classifier mes dépenses et entrées d’argent par un simple choix dans un menu local.

La colonne A contient chaque mouvement fait sur mon compte. (Valeur numérique)

La colonne B est une formule SI =SI(A1>0;"Entrée";"Sortie").

La colonne C proposerait en menu local les catégories générales (de dépenses ou d’entrées d’argent, en fonction de la réponse de la colonne B).

La colonne D proposerait en menu local un choix de détails de la catégorie donnée en résultat en colonne C.

Le résultat serait :

A1 : -65,70 | B1 : Sortie | C1 : Transport | D1 : Carburant

A2 : +5,98 | B2 : Entrée | C2 : Remboursement | D2 : Docteur

Comment générer ces colonnes C et D ?

En espèrant trouver de l’aide, je vous remercie par avance !

iPad Air, iOS 11.2.6

Publiée le

Répondre

Le contenu de la page a été chargé

7 mars 2018 à 02h12 en réponse à lauragesa En réponse à lauragesa

Vous ne pouvez pas modifier un menu local à la volée, mais vous pouvez rendre visible ou invisible un menu local en fonction d'un autre menu local.


Créons une cellule B2 offrant le choix {Transport, Remboursement}, une cellule B3 offrant le choix du type de transport, et une cellule B4 offrant le choix du type de remboursement.


Dans la colonne C, mettons «visible» ou «invisible» en fonction du choix dans la cellule B2.


Dans la cellule C3, mettons la formule:

=SI(B2="Transport";"visible";"invisible")

Dans la cellule C4, mettons la formule:

=SI(B2="Remboursement";"visible";"invisible")

Ce qui donne:

Fichier chargé par un client

Fichier chargé par un client

À l'aide de la fonctionnalité «Trier et filtrer» dans la barre d'outils, créons un filtre qui cache toutes les rangées dont la colonne C dit «invisible»:

Fichier chargé par un client

Pour ne pas mélanger l'utilisateur, cachons la colonne C:

Fichier chargé par un client

Et voilà. Lorsque «Remboursement» est choisi, seul «Type de remboursement» est visible. «Type de transport» est invisible.

7 mars 2018 à 02h12

Répondre Utile
Profil de l’utilisateur : lauragesa

Question : Menu local imbriqué