Frage:

Frage: Gatekeeper Funktion "Erlauben" wirkungslos

Hallo liebe Gemeinde,


habe folgendes Notebook: MacBook Pro (Retina, 15', Mitte 2014)

mit macOS High Sierra Version 10.13.2 (17C88).


Ich will eine nicht signierte Software (Parallels) starten und die Sicherheitseinstellung (gatekeeper) lassen dies trotz

der Funktion "Erlauben" nicht zu.


Normalerweise konnte ich in den Sicherheitseinstellungen das "Laden der Systemsoftware des Entwicklers "xyz" erlauben. Die Meldung in den Systemeinstellungen steht dort auch, aber der Schalter "Erlauben" schient nicht zu funktionieren.

Trotz offenen Schloss und Adminrechten scheitert das Starten des installierten Programms danach erneut an der Fehlermeldung, dass die Sicherheitseinstellungen dies nicht zulassen würden.


Auch ein Start mit dem Finder aus dem Verzeichnis mit "crtl"-Taste und Kontextmenü "öffnen" führt mich nur wieder die in Sicherheitseinstellungen.


Hat hier jemand bitte sachdienliche Hinweise?

Vorab besten Dank


Peter

MacBook Pro

Gepostet am

Antworten
Frage gekennzeichnet als Gelöst
Antwort:
Antwort:

Unter High Sierra ist es erst Mal von Haus aus nicht möglich Gatekeeper unter den Systemeinstellung vollständig zu deaktivieren. Um diese Möglichkeit wieder zu erhalten, muss man im Terminal folgenden Befehl eingeben:


sudo spctl --master-disable


Anschließend wird diese Möglichkeit wieder in den Systemeinstellungen unter Sicherheit angezeigt.


Wenn dies nicht hilft, dann versuche mal einen Neustart. Scheinbar hat sich da ein Prozess aufgehangen.

Gepostet am

Seiteninhalt wurde geladen

Frage gekennzeichnet als Gelöst

16. Jan. 2018, 15:27 als Antwort auf peter-m Als Antwort auf peter-m

Unter High Sierra ist es erst Mal von Haus aus nicht möglich Gatekeeper unter den Systemeinstellung vollständig zu deaktivieren. Um diese Möglichkeit wieder zu erhalten, muss man im Terminal folgenden Befehl eingeben:


sudo spctl --master-disable


Anschließend wird diese Möglichkeit wieder in den Systemeinstellungen unter Sicherheit angezeigt.


Wenn dies nicht hilft, dann versuche mal einen Neustart. Scheinbar hat sich da ein Prozess aufgehangen.

16. Jan. 2018, 15:27

Antworten Hilfreich (2)

16. Jan. 2018, 15:29 als Antwort auf RichardB. Als Antwort auf RichardB.

Hallo RichardB,


vielen Dank für die schnelle Antwort.

Hab ich probiert und mit Hilfe des Terminals die Sicherheitseinstellungen komplett deaktiviert.

Danach funzte es.

Nach erneuter Aktivierung der Sicherheitseinstellung ist der untere Eintrag nach dem Neustart zwar wieder verschwunden, werde mir den Terminal Befehl daher merken!


Beste Grüße



Peter

16. Jan. 2018, 15:29

Antworten Hilfreich

27. Mär. 2018, 12:43 als Antwort auf RichardB. Als Antwort auf RichardB.

Hallo,


ich wollte eben auch Parallels 13 auf meinem iMac (High Sierra 10.13.3) installieren.


Selbiges Problem wie hier beschrieben, trotz Eingabe des Befehls im Terminal und "ohne Einschränkungen" funktioniert "Erlauben" bei mir nicht. Bin als Admin angemeldet, kein weiterer User aktuell aktiv (sprich alle abgemeldet) und auch das Schloss unten ist geöffnet.


Keine Chance Parallels installiert zu bekommen? Was kann ich noch tun?


Vielen Dank schon mal.

27. Mär. 2018, 12:43

Antworten Hilfreich

25. Apr. 2018, 10:26 als Antwort auf bitstep Als Antwort auf bitstep

Du kannst mal folgendes Versuchen:


  1. system security deaktivieren:
    • im recovery mode booten: Beim Neustart CMD + R drücken
    • unter Dienstprogramme das Terminal auswählen und die system security deaktivieren: csrutil disable

    Neustart

  2. Änderung vornehmen
  3. system security aktivieren (aus Sicherheitsgründen):
    • im recovery mode booten: Beim Neustart CMD + R drücken
    • unter Dienstprogramme das Terminal auswählen und die system security deaktivieren: csrutil enable
  • Neustart
  • 25. Apr. 2018, 10:26

    Antworten Hilfreich (2)

    07. Mai. 2018, 20:48 als Antwort auf RichardB. Als Antwort auf RichardB.

    Hallo Richard,

    vielen Dank für deine detaillierte Beschreibung!

    • Solange ich die System Security deaktiviert habe, läuft die VM-Box tadellos.
    • Nachdem ich sie wieder aktiviere lt. deiner Beschreibung oben, bekomme ich die Fehlermeldung "Kernel Driver not installed (rc=-1908)".
    • Den Befehl "sudo spctl --master-disable (bzw. enable)" habe ich ausgeführt, ebenfalls kein Erfolg.
    • Ich bekomme die Meldung in den Sicherheitseinstellungen nicht, um die Oracle Software freizugeben.
    • VM Box habe ich in der Firewall und in den Privatsphäre Einstellungen freigegeben
    • aktuellste Version von High Sierra 10.13.4 installiert
    • aktuellste Version von VM Box 5.2.10 + Extension Pack 5.2.10 installiert
    • alles installiert als Admin User


    Nach gefühlten 100.000 gelesenen Foren-Beiträgen (Apple sagt das Zertifikat fehlt - daher Problem von Oracle; Oracle sagt es ist ein Apple Problem und muss von Apple gelöst werden) und mehreren Tagen intensiver Suche und mehrfacher Neuinstallation der VM Box habe ich immer noch keine "saubere" Lösung gefunden.


    Hat noch jemand einen Tip für mich?

    Oder muss ich mir einen Programmierer suchen, der den Kernel Driver für die VM Box über das Terminal irgendwie installiert/freischaltet?


    Vielen Dank im Voraus für eure Bemühungen!

    07. Mai. 2018, 20:48

    Antworten Hilfreich

    09. Mai. 2018, 17:06 als Antwort auf cse Als Antwort auf cse

    Ich beantworte meine Frage selber bzw. konnte mir mein Arbeitskollege weiterhelfen.

    Für alle bei denen es noch nicht funktioniert hier:

    Starten im Recovery Modus wie von Richard beschrieben, im Terminal folgendes eingeben:

    spctl kext-consent add VB5E2TV963

    (ist zwar für V5.1.18 - ging bei mir aber in V5.2.10 auch)

    Neustart - Sicherheitseinstellungen öffnen -> Meldung erscheint wieder und bestätigen -> VM Box startet, Fehlermeldung zu Kernel Driver ist verschwunden.

    LG

    Claudia

    09. Mai. 2018, 17:06

    Antworten Hilfreich

    07. Aug. 2018, 11:48 als Antwort auf RichardB. Als Antwort auf RichardB.

    Hallo RichardB,


    ich konnte tatsächlich auf Parallels zugreifen als ich die System Security deaktiviert hatte, in dem Moment wo diese wieder aktiviert wird bekomm ich leider jedoch wieder das gleiche Problem wie zu Anfang, dass ich aufgefordert werde die Anwendung zuzulassen, was (trotz "keiner Einschränkungen" in den Sicherheitseinstellungen und entriegeltem Schloss) nicht funktioniert...ich kann doch nicht jedesmal meinen Computer so umständlich entriegeln, nur weil ich mal kurz in andere Systeme schlüpfen möchte, oder?

    07. Aug. 2018, 11:48

    Antworten Hilfreich (1)

    02. Okt. 2018, 17:09 als Antwort auf peter-m Als Antwort auf peter-m

    SORRY. ICH HABE KEINE LÖSUNG - aber das gleiche Problem.

    Bei mir ist es der nvidia Treiber, der sich nicht installieren läßt.

    Auch meine Virtuelle Maschine mit VMWare Fusion funktioniert NICHT.

    Die "tolle APPLE System Security" (SIS) blokiert.

    Der Workarround mit den deaktivieren des SIS funktioniert.

    cmd + R Reboot

    Terminal: csrutil disable

    Neustart

    Wird die System Security (SIS) wieder aktiviert (csrutil enable), startet das System nicht mehr hoch. Stelle ich den Treiber wieder zurück auf „Default macOS Graphics Driver“ startet das System wieder, aber der nvidia Treiber ist OFF und auch die VMWare Maschinen können nicht mit aktivierter SIS starten.

    Die Funktion "Erlauben" über die Systemeinstellung "Sicherheit" funktioniert NICHT!

    Man klickt. Nichts passiert. Es wird KEINE Ausnahme generiert.

    Weder bei dem nvidia Treiber, noch bei VMWare Fusion.

    Ich bin sprachlos wie ignorant bei Apple entwicklet wird.

    Vom Benutzer hochgeladene Datei


    02. Okt. 2018, 17:09

    Antworten Hilfreich
    Benutzerprofil für Benutzer: peter-m

    Frage: Gatekeeper Funktion "Erlauben" wirkungslos