Ankündigung: Vorbereitung auf macOS Mojave


Dank Funktionen wie dem Dunkelmodus, Stapeln und vier neuen integrierten Apps kannst du unter macOS Mojave mit einem Klick noch mehr erreichen. Auf macOS Mojave vorbereiten > https://support.apple.com/de-de/macos/mojave

Frage:

Frage: Benutzer ignorieren auf APFS Volumes

Hallo,


gibt es eine Möglichkeit unter Sierra die 'Benutzer ignorieren Funktion' für HighSierra Volumes wieder verfügbar zu machen?

Unter Sierra werden die persönlichen Ordner alle gesperrt und es gibt den Auswahlpunkt im Infofenster nicht mehr.

Bug oder Absicht??


Grüße Achim

MacBook Pro, iOS 11.2.6

Gepostet am

Antworten

Seiteninhalt wurde geladen

10. Mär. 2018, 10:50 als Antwort auf achimf Als Antwort auf achimf

Hallo Achim,
wir brauchen bitte noch mehr Informationen, um nach einer Lösung suchen zu können.

  • Hast du ein Screenshot von der fraglichen Funktion?
  • Das Problem besteht nur auf einem MacBook Pro, wo die neuste Version von macOS High Sierra installiert ist?

Vielen Dank und ein schönes Wochenende.
Lieber Gruß!

10. Mär. 2018, 10:50

Antworten Hilfreich

13. Mär. 2018, 13:55 als Antwort auf AnneBa Als Antwort auf AnneBa

Ja, kein Problem!

Der erste Screenshot zeigt die Zugriffsrechte von HighSierra aus auf die Sierra SSD. Hier ist die alt bekannte Auswahlmöglichkeit "Eigentümer ignorieren" vorhanden!

Vom Benutzer hochgeladene Datei

Der nächste Screenshot zeigt das HighSierra Volume bei laufendem Sierra OS - also umgekehrt!

Hier kann ich keine Auswahl treffen und alle Verzeichnisses innerhalb des Benutzer Accounts sind für Zugriffe gesperrt!

Vom Benutzer hochgeladene Datei


Die Verzeichnisse lassen sich auch nicht ohne weiteres als SharePoint freigeben!


Irgend eine Idee???

13. Mär. 2018, 13:55

Antworten Hilfreich

15. Mär. 2018, 13:55 als Antwort auf achimf Als Antwort auf achimf

Hallo achimf,

danke für deine Antwort und Geduld bisher.

Wir denken es wäre am besten, du kontaktierst direkt den AppleCare Support für weitere Unterstützung mit dem Anliegen. Erreichbar per Telefon und im Chat. Apple – Support – Produktauswahl

Viel Erfolg und einen angenehmen Tag.
Grüße!

15. Mär. 2018, 13:55

Antworten Hilfreich

15. Mär. 2018, 17:36 als Antwort auf achimf Als Antwort auf achimf

Zugriffsrechte ignorieren ist generell nicht möglich, wenn eine Festplatte oder Partition für Time Machine benutzt wird, und es ist auch nicht möglich für eine Festplatte, auf der ein System installiert ist. Das soll verhindern, dass man einfach in fremde Benutzerordner hineinschaut. Für die Systemplatte mit dem installierten System und den Benutzerordnern geht das auf keinem meiner Macs, weder unter Sierra noch High Sierra.

Ist dein erstes Bildschirmfoto von einer Systemfestplatte? Hast du eventuell die System Integrity Protection deaktiviert?

15. Mär. 2018, 17:36

Antworten Hilfreich

15. Mär. 2018, 18:04 als Antwort auf Leonie Als Antwort auf Leonie

Hallo Leonie,

danke für Deine Antwort!

Zugriffsrechte ignorieren ist generell nicht möglich, wenn eine Festplatte oder Partition für Time Machine benutzt wird, und es ist auch nicht möglich für eine Festplatte, auf der ein System installiert ist.

Das stimmt so leider nicht, wie Du aus meinen beiden Screenshots ersehen kannst!

Vorab: Keine der FPs wird für TimeMachine genutzt!!

Ich habe schon seit geraumer Zeit zwei SSDs in meinem MacBook verbaut und bisher immer zwei oder mehr Systeme installiert gehabt. War bisher nie ein Thema - deshalb poste ich das Problem ja!

Wie Du siehst ScreenShot 1 kann man sehr wohl Benutzer ignorieren aktivieren, auch wenn ein OS installiert ist! Nur eben nicht im Falle des APFS-Volumes. ScreenShot 2

Geht übrigens auch mit externen Volumes problemlos. (Allerdings habe ich das noch nicht mit APFS ausprobiert - gilt es mal zu testen!)


Grüße Achim

15. Mär. 2018, 18:04

Antworten Hilfreich

16. Mär. 2018, 09:29 als Antwort auf achimf Als Antwort auf achimf

Wie Du siehst ScreenShot 1 kann man sehr wohl Benutzer ignorieren aktivieren, auch wenn ein OS installiert ist!

Das hat mich auch sehr überrascht, dass du es bisher so verwenden konntest. Es sollte nicht möglich sein.


Hast du schon versucht "diskutil" im Terminal aufzurufen und die disableownership flag zu setzen?

Das geht nur als root, so sei sehr vorsichtig


Im Terminal:

sudo diskutil disableOwnership device


"device" sollte der Pfad zur Festplatte sein.


enableOwnership device

Enable ownership of a volume. The on-root-disk Volume Data-

base at /var/db/volinfo.database is manipulated such that the

User and Group ID settings of files, directories, and links

(file system objects, or "FSOs") on the target volume are

taken into account.


This setting for a particular volume is persistent across

ejects and injects of that volume as seen by the current OS,

even across reboots of that OS, because of the entries in this

OS's Volume Database. Note thus that the setting is not kept

on the target disk, nor is it in-memory.


For some locations of devices (e.g. internal hard disks), con-

sideration of ownership settings on FSOs is the default. For

others (e.g. plug-in USB disks), it is not.


When ownership is disabled, Owner and Group ID settings on

FSOs appear to the user and programs as the current user and

group instead of their actual on-disk settings, in order to

make it easy to use a plug-in disk of which the user has phys-

ical possession.


When ownership is enabled, the Owner and Group ID settings

that exist on the disk are taken into account for determining

access, and exact settings are written to the disk as FSOs are

created. A common reason for having to enable ownership is

when a disk is to contain FSOs whose User and Group ID set-

:

disableOwnership device

Disable ownership of a volume. See enableOwnership above.

Running as root is required.



"device" sollte der Pfad zur Festplatte sein.

16. Mär. 2018, 09:29

Antworten Hilfreich
Benutzerprofil für Benutzer: achimf

Frage: Benutzer ignorieren auf APFS Volumes