F: OSX Sierra 10.12.4:  Apfelmenu => Über diesen Mac => Systembericht => USB: Fenster bleibt leer

D.h. es erfolgt keine Anzeige über angeschlossenen USB Geräte, das sich öffnende Fenster bleibt einfach leer. Nur unten in der Statuszeile dreht das Zahnrad langsam vor sich hin.

 

Immer wenn dieses "Problem" auftritt gibt es diverse Probleme:

Ein Über USB angeschlossener Scanner reagiert nicht mehr

Ein über Thunderbolt => USB Adapter USB angeschlossener Drucker reagiert nicht mehr.

Ein über USB angeschlossener Chipkartenleser "cyberjack" reagiert nicht mehr

Das Apple Datensammeltool capture_data.dmg hängt sich im Schritt Creating System Profile Report auf.

 

Ein Reboot des Rechners behebt das Problem zuverlässig. Nach 10 Minuten bis 1 Stunde tritt der Effekt jedoch wieder auf.

Der Rechner ist nagelneu, Parallels ist installiert - ich bin mir nicht sicher wann das Problem während der Installation zum ersten mal auftrat. Ich denke nicht das es ein USB Problem ist - zumindestens bei dem Drucker geht es ja über den Thunderbolt Bus (und erst von da über einen Adapter auf USB). Irgend ein Stück Systemsoftware muß sich aufhängen. fsck ist OK, die System Hardwarediagnose ist fehlerfrei.

Der Apple Support konnte leider nicht helfen: NVRam Reset, plist löschen, eine Neuinstallation über das bestehende System halfen nicht. Die nächste Empfehlung ist ein "clean install" (löschen der Festplatte und neues Aufsetzen des Systems). Das würde ich dann tun - aber trotzdem frage ich noch einmal hier ob doch noch jemand eine Idee hat wie ich das umgehen kann.

 

Grüße, Jens

Mac Pro (Late 2013), Sierra 10.12.4

Gepostet am 20.04.2017 04:01

  • Hilfreiche Antworten
  • Alle Antworten
Seite 1 Weiter
  • von Leonie,

     Leonie 20.04.2017 07:47 als Antwort auf jenstw
    Level 10 Stufe 10 (120.395 Punkte)
    expertise.macosx
    Mac OS X
    20.04.2017 07:47 als Antwort auf jenstw

    Wie sind die USB Geräte angeschlossen? Verwendest Du ein HUB, Jens, oder einen USB Anschluß direkt am Gehäuse des Mac Pro?

    Die Tastatur und Trackpad scheinen immer zu gehen? Oder sind die über Bluetooth angeschlossen?

    20.04.2017 07:47

  • von jenstw,

     jenstw 20.04.2017 08:40 als Antwort auf Leonie
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    20.04.2017 08:40 als Antwort auf Leonie

    Das ist eine längere Geschichte.

    Anfangs gab es am Gerät nur Tastatur+Maus über Bluetooth. Der Kartenleser war einsam und allein am Mac angeschlossen - ich habe mehrere der USB Ports ausprobiert. Stets fiel der Chipleser nach einigen Minuten aus und ich musste rebooten.

    Einige Tage später gab es einen Thunderbolt Bus, ein angeschlossenes Raid über das ein Thunderbolt- USB Adapter angeschlossen war. Der dort angeschlossenen Drucker druckte - oder eben plötzlich nicht mehr. Auch da half stets ein Reboot. Genau aus diesem Grund verwende ich ihn nicht mehr sondern drucke über LAN (verkabelt).

    Aktuell hänge ein 10 Port Hub mit dickem Netzteil an einem der USB Ports. Von dem geht eine

    USB Tastatur ab => die geht immer

    Der sctReinerChipleser => Für die Kontoverwaltung. davor ist halt immer ein Reboot notwendig wenn ich ihn verwenden will.

    Der iX500 Fujitsu Scanner: Verwendbar nur nach Reboot.

    ... und die Maus ist über Bluetooth.

    Bevor ich Scanner oder Leser verwenden will rufe ich kurz die Systeminfomation => USB Bus auf. Wird das Fenster angezeigt funktionieren die Geräte. Bleibt das Fenster leer => Reboot.

    Schließe ich im Fehlerfall eine USB Festplatte oder ein Stick an dem USB Switch an funktionieren Platte oder Switch ohne Probleme.

    Am Mac ist seit drei Tagen zusätzlich direkt ein USB DVD Laufwerk angeschlossen, dieses funktioniert immer und ohne Reboot.

     

    Der Netzwerkdrucker ist ein Multifunktionsgerät. Dessen Scanner kann ich immer verwenden.

     

    Wie geschrieben: Das Problem betrifft vorwiegend den Scanner, die Systeminformation, den Datensammelscript. Vielleicht ist es ein Problem in Zusammenhang mit Parallels. Ein typisches USB/Switch Hardwareproblem schließe ich aus.

    Gruß Jens

    20.04.2017 08:40

  • von Redarm,

     Redarm 20.04.2017 18:11 als Antwort auf jenstw
    Level 3 Stufe 3 (530 Punkte)
    expertise.macosx
    Mac OS X
    20.04.2017 18:11 als Antwort auf jenstw

    So etwas Ähnliches passiert auch wenn z.B. die Software für einen Samsung T3 SSD installiert wurde.

    Der installiert dann eine Version vom SATSMART driver, welche debug Nachrichten in die System Information bring, das dann nichts anzeigen kann.

    (SATSMARTDriver.kext und SATSMARTLib.plugin)

    Vielleicht bringt dich das etwas weiter.

     

    Siehe auch hier (in Englisch):

    https://github.com/kasbert/OS-X-SAT-SMART-Driver/issues/22

    20.04.2017 18:11

  • von jenstw,

     jenstw 20.04.2017 23:33 als Antwort auf Redarm
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    20.04.2017 23:33 als Antwort auf Redarm

    Danke. immerhin eine Idee - leider habe ich nichts dergleichen auf dem Rechner.

    Eine Updateinstallation hat nichts gebracht. Für einen "Clean" install habe ich noch keine Zeit gefunden und mag auch nicht so gern.

    Immerhin habe ich heute die Garmin Software deinstalliert - ohne Erfolg. Jegliche Idee ist immer noch willkommen.

    20.04.2017 23:33

  • von Redarm,

     Redarm 20.04.2017 23:48 als Antwort auf jenstw
    Level 3 Stufe 3 (530 Punkte)
    expertise.macosx
    Mac OS X
    20.04.2017 23:48 als Antwort auf jenstw

    Zur Zeit, wo die USB Anzeige leer bleibt und du den Befehl in Terminal (zu finden in /Programme/Dienstprogramme/, oder über Spotlight) laufen lässt, was ist dann die Ausgabe?

     

    /usr/sbin/system_profiler -nospawn -xml SPUSBDataType -detailLevel full | head -n 30

     

    Nach dem Einfügen in Terminal 'enter' drücken.

    20.04.2017 23:48

  • von jenstw,

     jenstw 21.04.2017 00:15 als Antwort auf Redarm
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    21.04.2017 00:15 als Antwort auf Redarm

    Ich habe den Befehl mit funktionierenden Computer ausprobiert:

     

    Last login: Fri Apr 21 00:00:14 on console

    Jenss-Mac-Pro:~ jens$ /usr/sbin/system_profile -nospawn -xml SPUSBDataType -detailLevel full | head -n 30

    -bash: /usr/sbin/system_profile: No such file or directory

    Jenss-Mac-Pro:~ jens$ /usr/sbin/system_profiler -nospawn -xml SPUSBDataType -detailLevel full | head -n 30

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <array>

      <dict>

      <key>_SPCommandLineArguments</key>

      <array>

      <string>/usr/sbin/system_profiler</string>

      <string>-nospawn</string>

      <string>-xml</string>

      <string>SPUSBDataType</string>

      <string>-detailLevel</string>

      <string>full</string>

      </array>

      <key>_SPCompletionInterval</key>

      <real>0.12603700160980225</real>

      <key>_dataType</key>

      <string>SPUSBDataType</string>

      <key>_detailLevel</key>

      <integer>-1</integer>

      <key>_items</key>

      <array>

      <dict>

      <key>_items</key>

      <array>

      <dict>

      <key>Built-in_Device</key>

      <string>Yes</string>

      <key>_items</key>

      <array>

    Jenss-Mac-Pro:~ jens$

     

    ... und das Terminal 5 Minuten stehen gelassen. Innerhalb dieser Zeit ist der Fehler auch prompt aufgetreten, hier die entsprechende Ausgabe:

    ********************************************* Und jetzt der Fehlerfall: 21-apr-2017 00:08

    Jenss-Mac-Pro:~ jens$

    Jenss-Mac-Pro:~ jens$ /usr/sbin/system_profiler -nospawn -xml SPUSBDataType -detailLevel full | head -n 30

     

    D.h. die Ausgabe hängt, nach Eingabe des Befehls im Fehlerfall und "Enter" hängt sich die Ausgabe auf, es passiert gar nichts und das Kommando kommt nicht zurück.

    21.04.2017 00:15

  • von Redarm,

     Redarm 21.04.2017 12:33 als Antwort auf jenstw
    Level 3 Stufe 3 (530 Punkte)
    expertise.macosx
    Mac OS X
    21.04.2017 12:33 als Antwort auf jenstw

    Schade, wär auch zu einfach gewesen.  Zurück an Leonie.

    21.04.2017 12:33

  • von jenstw,

     jenstw 21.04.2017 23:58 als Antwort auf Redarm
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    21.04.2017 23:58 als Antwort auf Redarm

    Ich bin immer noch ratlos. Wenn ich mir so das Logging anschaue fällt mir die immer wiederkehrende Zeile

     

    Apr 21 19:58:33 Jenss-Mac-Pro com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit

     

    auf. Was mag das sein, ob das ein Problem ist?

    Gruß Jens

    21.04.2017 23:58

  • von Redarm,

     Redarm 22.04.2017 00:28 als Antwort auf jenstw
    Level 3 Stufe 3 (530 Punkte)
    expertise.macosx
    Mac OS X
    22.04.2017 00:28 als Antwort auf jenstw

    Was mag das sein, ob das ein Problem ist?

    Ich glaube diese info hat schon fast jeder mal gesehen, wo Mac und iPhone vorhanden sind.

    Auf alle Fälle kenne ich diese Linie auch.

     

    Wenn Englisch kein Problem ist, hier gibt's eine relativ gute Erklärung:

    https://apple.stackexchange.com/questions/155458/strange-message-in-console-abou t-dirtyjetsammemorylimit-key

     

    Ich würde mal Hardware testen und direct einzeln, wenn's sein muß, am Mac anstecken (und den Hub mal aus dem Bild lassen).

    Ein typisches USB/Switch Hardwareproblem schließe ich aus

    Warum?

    22.04.2017 00:28

  • von jenstw,

     jenstw 22.04.2017 00:53 als Antwort auf Redarm
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    22.04.2017 00:53 als Antwort auf Redarm

    Danke für die Antwort.
    Der Fehler:   Keine Reaktion/Zugriff auf den Scanner, Chipkartenleser, Drucker, Aufhängen beim Abfragen der USB Systeminformation trat auch ohne Hub auf - als dieser noch im Laden lag. Und selbstv. habe ich auch ohne weitere USB Geräte, d.h. nur der Scanner angesteckt, getestet.

    Auch den Treiber des Chipkartenlesers, meines ersten USB Gerätes, habe ich probeweise gelöscht. Leider war auch das kein Erfolg.

    Gruß Jens

    22.04.2017 00:53

  • von Redarm,

     Redarm 22.04.2017 13:36 als Antwort auf jenstw
    Level 3 Stufe 3 (530 Punkte)
    expertise.macosx
    Mac OS X
    22.04.2017 13:36 als Antwort auf jenstw

    Gibt's genug Platz?  Dann könnte man, statt löschen, noch zusätzlich eine kleine ca. 30 GB Partition machen und dort frisch installieren, als Startvolumen setzen und testen, ob's Drittanbieter Software, Apple Software, oder Hardware ist.

    22.04.2017 13:36

  • von jenstw,

     jenstw 23.04.2017 08:05 als Antwort auf Redarm
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    23.04.2017 08:05 als Antwort auf Redarm
    1. OK. Ich habe eine externe USB3 Festplatte direkt an den Mac gestöpselt, diese komplett gelöscht und ein System drauf installiert, davon gebootet. Dann habe ich darauf den ScanSnapmanager, die Software mit der der Scanner läuft, installiert und bin wieder schlafen gegangen.

    Zwei Stunden später habe ich mir die Geschichte angesehen:

    Apple Menü => Über diesen Mac => Systembericht => USB    ergab ein leeres Fenster. Der Scanner hängt, ein Reboot war nur möglich nach Abschuss von "ScanMap".

     

    1. D.h. der Fehler tritt auch bei einem neuen System auf. Und am Scanner liegt es sicher nicht da ich mit einem Chipkartenleser bei der Installation die gleichen Probleme hatte, zu diesem Zeitpunkt hing der Scanner noch an Windows10 und hat sich dort stets sehr wohl gefühlt.

    Damit bin ich mir nun sicher ein defektes Montagsgerät gekauft und ein Problem zu haben. USB Festplatten laufen stets prima, der Apple Hardwaretest im Gerät findet keine Probleme und wenn ich jemanden erkläre ein ominöser Scanner der über USB angeschlossen wird würde ab und zu nicht gehen - na super. Noch dazu war der Fehler beim Anruf beim Support stets nicht vorführbar - als es endlich beim letzten Kontakt klappte und der Rechner hing war der gute Mann Null interessiert. "Das Datensammelscript hängt? Tjaaaa... Neuinstallation!" Schicke ich den Rechner in dem Zustand ein kommt er "geprüft" wieder zurück, und das wars.

     

    Ganz 100% ist das noch nicht da immer noch der USB-Hub und an dem der Chipkartenleser und der Scanner zusammen am Rechner hängen. Ein schlechtes "Qi" des Chipkartenlesers ist noch möglich - aber nicht wahrscheinlich da ich in Vergangenheit auch mit direkt angeschlossenen Scanner getestet habe.

    Also ein weiterer Versuch: Tritt der Fehler auch bei einem System in Auslieferungszustand auf?

    Ich habe die externe Festplatte nochmals gelöscht und erneut neu installiert. Und diesmal ist wirklich alles an Hardware ab:

     

    Maus, Tastatur: Bluetooth

    Netzwerk: WLAN

    Am Gerät stecken nur noch Monitor, externe Platte und das Stromkabel.

     

    Die ersten 4 Stunden ist nichts passiert, rufe ich den Systembericht auf wird der USB Bus bisher angezeigt. Im Gegenteil: nach geraumer Zeit werde ich abgemeldet und das Passwort wird fällig. ich werde mir mal anschauen ob der Bildschirmschoner schuld ist.

    Ich würde gern ein Endlosscript so wie Redarm vorgeschlagen hat laufen lassen

    Marke

    /usr/sbin/system_profiler -nospawn -xml SPUSBDataType -detailLevel full | head -n 30

    <?xml version="1.0" encoding="UTF-8"?>   >> Protokolldatei

    time   >> Protokolldatei

    goto marke

    in der Hoffnung endlich etwas bei Support Vorzeigbares zu bekommen. Vielleicht bit es mit einer in etwa Zeitangabe auch Hoffnung einen Hinweis im Logging zu finden.

    Das Problem ist: ich habe geballt gemein keine Ahnung von Shellprogrammierung, meine Versuche damit sind 20 Jahre her. Gehen Schleifen überhaupt? Wie peinlich, ich werde beginnen zu nachzulesen.

    Gruß Jens

    23.04.2017 08:05

  • von jenstw,

     jenstw 23.04.2017 08:27 als Antwort auf jenstw
    Level 1 Stufe 1 (8 Punkte)
    expertise.macosx
    Mac OS X
    23.04.2017 08:27 als Antwort auf jenstw

    Ich versuche es als blutige Anfänger mal so:

    #!/bin/bash

    /usr/sbin/system_profiler -nospawn -xml SPUSBDataType -detailLevel full | head -n 30 > test

     

    while true

    do

    date

    date >> test

    /usr/sbin/system_profiler -nospawn -xml SPUSBDataType -detailLevel full | head -n 1 >> test

    done

    23.04.2017 08:27

  • von Redarm,

     Redarm 23.04.2017 21:14 als Antwort auf jenstw
    Level 3 Stufe 3 (530 Punkte)
    expertise.macosx
    Mac OS X
    23.04.2017 21:14 als Antwort auf jenstw

    Geht das nicht etwas zu schnell?

    Ist jede Minute nicht genug?

    <...>

    sleep 60

    done

     

    Wenn die Zeit bekannt ist, könnte man eine Systemdiagnose erstellen und die Logs begutachten:

    http://adcdownload.apple.com/OS_X/OS_X_Logs/sysdiagnose_Logging_Instructions.pdf

    23.04.2017 21:14

Seite 1 Weiter