Ankündigung: Vorbereitung auf macOS Mojave


Dank Funktionen wie dem Dunkelmodus, Stapeln und vier neuen integrierten Apps kannst du unter macOS Mojave mit einem Klick noch mehr erreichen. Auf macOS Mojave vorbereiten > https://support.apple.com/de-de/macos/mojave

Frage:

Frage: Systemsprache plötzlich Englisch, kann aber nicht mehr in Deutsch geändert werden.

Hi,


bei meinem iMac (21,5 Zoll 2011) mit macOS Sierra, Version 10.12.6, ist die Systemsprache plötzlich Englisch.

Wenn ich die Sprache in der Systemeinstellung ändern möchte, steht Englisch drin und es lässt sich keine Sprache hinzufügen. Auch über das Terminal geht es nicht. Wenn ich einen neuen Benutzer anlege ist Deutsch drin und bleibt. Auch über die root Rechte kann ich Deutsch eingeben, aber nach dem Neustart ist es wieder Englisch.

Was kann ich tun?


Gruß


sima76

iMac

Gepostet am

Antworten

Seiteninhalt wurde geladen

08. Aug. 2017, 15:21 als Antwort auf sima76 Als Antwort auf sima76

Hallo sima76,

danke für die Nutzung der Apple Support Communities. Wir haben verstanden, dass sich die macOS Systemsprache ohne Grund ändert.

Was du beschreibst ist schon merkwürdig und sollte so natürlich nicht sein. Bevor du jetzt aber vielleicht eine Neuinstallation in Betracht ziehst, versuche noch bitte folgendes.
  1. Starte dein iMac im gesicherten Modus, um den Einfluss von Drittanbietersoftware zu unterbindnen Im gesicherten Modus Probleme mit dem Mac eingrenzen - Apple Support
  2. Öffne die Systemeinstellungen > Sprache & Region
  3. Achte darauf das dort, in der linken Spalte für bevorzugte Sprachen, Deutsch als primäre Sprache ausgewählt wurde und ganz oben ist
  4. Ändere auch die Region bitte auf Deutschland
  5. Schließe die Systemeinstellungen und starte dein iMac erneut
Sollte das wirklich nicht helfen, mache erstmal ein aktuelles Backup vom iMac und führe dann die Wiederherstellung aus.

Backup des Mac erstellen – Offizieller Apple Support

Informationen zu macOS-Wiederherstellung - Apple Support

Erneute Installation von macOS - Apple Support


Viel Erfolg und einen schönen Tag.
Gruß!

08. Aug. 2017, 15:21

Antworten Hilfreich

08. Aug. 2017, 17:09 als Antwort auf Becci Als Antwort auf Becci

Hallo,


leider funktioniert das auch nicht. Die primäre Sprache steht auf Englisch, die Region auf Deutschland, aber die primäre Sprache lässt sich durch + einfach nicht hinzufügen, übrigens keine aus der rechten Spalte. Es erscheint und bleibt nur Englisch in der linken Spalte.

Bleibt jetzt wohl nur die Wiederherstellung😠


Gruß


sima76

08. Aug. 2017, 17:09

Antworten Hilfreich

10. Aug. 2017, 09:13 als Antwort auf sima76 Als Antwort auf sima76

Habe jetzt wiederhergestellt, ich könnte ausflippen, nichts hat sich geändert genau das selbe. Alles Englisch und es lässt sich wieder nichts umstellen.😮

10. Aug. 2017, 09:13

Antworten Hilfreich

18. Aug. 2017, 12:56 als Antwort auf sima76 Als Antwort auf sima76

Ich habe exakt das gleiche Problem und bin froh über die Erfahrungen, denn ich habe ebenfalls eine Wiederherstellung geplant, die ich mir jetzt schenke.

Jetzt das Kuriose: Ich habe 2 weitere Benutzer eingerichtet und bei diesen besteht das Problem nicht!

Sehr seltsam und nervtötend.

18. Aug. 2017, 12:56

Antworten Hilfreich (1)

11. Sep. 2017, 20:34 als Antwort auf sima76 Als Antwort auf sima76

Hatte das gleich Problem auch bereits mit meinem MacBook pro vor einiger Zeit.


Damals lag es daran, dass ich über einen Online-Apple-Store in Amerika Software gekauft habe und dafür meine Region ändern musste.

Plötzlich war alles auf englisch und nichts half, kein sudo, kein Re-Install.


Irgendwie musste ich mich wieder bei meinem deutschen Store anmelden, plötzlich war wieder alles auf deutsch.

(wie und wo genau, weiß ich nicht mehr, sorry)


Macht überhaupt keine Sinn, Apple-Logik


Gruß

D.

11. Sep. 2017, 20:34

Antworten Hilfreich

27. Sep. 2017, 22:00 als Antwort auf peter85 Als Antwort auf peter85

entweder wie in nachstehender Antwort beschrieben:


"Zieh doch einfach die com.apple.languageassetd.plist aus der library (~/library/preferences) und eventuell auch die systempreferences.plist raus.

Dann Neustart und neu testen. Im Endeffekt sind das die Listen, die die Einstellungen in deinem Benutzerordner für Sprache und Systemsteuerung speichern. Aus dem Ordner rausziehen bedeutet, die muss sich neu anlegen."



Mir hat ein anderer "Trick" geholfen (muss man nicht verstehen):


Neuen User anlegen, z.B. "Test"

Rechner neu starten

Als "Test" einloggen - dieser kommt dann auch erst einmal in Englisch.

Hier kann man dann aber unter den Spracheinstellungen "Deutsch" auswählen und - viel wichtiger - auch speichern und als primäre Sprache festlegen.

Nun spricht "Test" deutsch.

Ausloggen

Rechner neu starten

Als Dein "normaler" User einloggen

Jetzt in die Spracheinstellungen gehen und siehe da, jetzt kann man auch dort "Deutsch" auswählen, speichern und als primäre Sprache auswählen.


Warum das so funktioniert - keine Ahnung.

Habe mich allerdings noch nicht getraut, "Test" wieder zu löschen...


Schönen Gruß

27. Sep. 2017, 22:00

Antworten Hilfreich

28. Sep. 2017, 08:47 als Antwort auf samsap Als Antwort auf samsap

moin

com.apple.languageassetd.plist.... ist bei mir nicht vorhanden

Test User habe ich angelegt, deutsch hinzufügen können und als primäre Sprache abgespeichert.


Nach Neustart keine Veränderung bei dem normalen User... nur Englisch und keine Einstellmöglichkeiten 😟

28. Sep. 2017, 08:47

Antworten Hilfreich

28. Sep. 2017, 10:57 als Antwort auf peter85 Als Antwort auf peter85

Ich hoffe, du hast die Tilde berücksichtigt bei ~/library/preferences

Sollte aber dennoch da sein. Schau doch mal im Testnutzer, ob du es da findest. Wenn ja, es da funktioniert, kopier doch die .plist und füge sie in ~/library/preferences (Nutzer-Library, geht auch im Finder (Alt-Taste gedrückt halten) und dann auf "Go" gehen. Dann die Library und die Preferences gehen und einfügen.

28. Sep. 2017, 10:57

Antworten Hilfreich

21. Feb. 2018, 19:58 als Antwort auf samsap Als Antwort auf samsap

Hat bei mir leider nicht funktioniert, aber der neue Benutzer hat wundersamerweise Deutsch als Systemsprache. Zumindest konnte ich es da einfach einstellen und good old englisch lösen. Ich war auch heute im Laden mit autorisiertem Apple Support. Auch die fanden die Lösung nicht!

21. Feb. 2018, 19:58

Antworten Hilfreich

21. Feb. 2018, 21:13 als Antwort auf Orangesu Als Antwort auf Orangesu

Hallo Orangesu!

Kannst du in den Systemeinstellungen > Sprache & Region deutsch auswählen oder funktoniert das auch nicht?

Kannst du bitte einen Screenshot von deinem Library Ordner posten

  • einfach im Menü > Gehe zu mit gedrückter ALT-Taste die Library auswählen und von dieser Ordnerliste einen Screenshot machen.

21. Feb. 2018, 21:13

Antworten Hilfreich
Benutzerprofil für Benutzer: sima76

Frage: Systemsprache plötzlich Englisch, kann aber nicht mehr in Deutsch geändert werden.